Help

Pro Tools


If you can’t see a Felt Instruments plugin on your instrument list, please, check the following:

Is your instrument track stereo?
Please, make sure that you’re loading the plugin onto a stereo track. The plugins don’t work in mono.

Is your Pro Tools compatible with 64-bit AAX format?
For Pro Tools, Felt Instruments plugins are presented in 64-bit AAX format. This requires Pro Tools 11 or newer to run.